Register with your Envato account

Support forums

Homepage Support Regolith WordPress Portfolio External fonts

External fonts

Homepage Support Regolith WordPress Portfolio External fonts

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #7213
    visall
    Participant

    Hey, its me again 🙂

    I have a problem regarding the embedding of fonts into the webside. We have a special font (called Masque) that we use for some trademarks (just for the names). So if the name appears in the text it should be written in that special font.

    How can I access a font (inside the text, via html code) that is uploaded to the ftp?
    If I use <font face=”Masque”>Test</font> it is working on my computer as the webside grabs it from my system but that won’t work if someone doesn’t have the font.

    Thank you so much in advance.

    Mareike

    #7219

    Hey,

    You can add custom font by following this topic under “Adding Custom Fonts in WordPress Using CSS3 @font-face” title.

    You can apply font using HTML like this:
    <span style="font-family: "Times New Roman", Georgia, Serif;">Test</span>

    #7223
    visall
    Participant
    This reply has been marked as private.
    #7226

    You can use this tool to generate all the necessary font files and their related CSS. Then you can copy and paste generated CSS code to child theme’s style.css file and refine locations to the font files so their matches the path font files are placed. Font can be applied according to my previous reply.

    #7227
    visall
    Participant
    This reply has been marked as private.
    #7230
    planetshine
    Keymaster

    Hey,

    It looks to me that you have included the fonts correctly. Try testing it like this:
    <span style="font-family: masque;">Test</span>

    #7239
    visall
    Participant

    Great, that’s it! Thank you so much!

    #7243
    visall
    Participant

    Haven’t looked for Internet Explorer (11) and Firefox(54.0 ???). There it is not working unfortunately although I uploaded eot, ttf and woff.
    Chrome and Safari are fine.

    Have you got any idea?

    #7248
    planetshine
    Keymaster

    Hey,

    The test page does not seem to be working anymore. Anyway, the font inclusion code looks fine so it should be working. Sometimes font can look a bit different between browsers. Have you tried making the text very large so the difference can be clearly seen?

    #7254
    visall
    Participant

    Hi,

    you can see it here: http://visall-brillenglas.de/gleitsicht/
    The subheadline is working perfekt in Chrome and on iPad, but not in iE and Firefox.
    As it is a very unusual font it would be visible even in small letters.

    #7268
    planetshine
    Keymaster

    Strange. It works fine with FireFox on mac. Maybe this is related to you case?
    https://stackoverflow.com/questions/30174622/font-face-not-working-with-specific-version-of-internet-explorer-11

    #7278
    visall
    Participant
    This reply has been marked as private.
    #7283
    planetshine
    Keymaster

    Great! 🙂

Viewing 13 posts - 1 through 13 (of 13 total)
You must have active support license to create new replies.

Learn more about Renewing Item Support and Themeforest Item Support Policy.

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close