Register with your Envato account

Support forums

Homepage Support Callisto Shopify Image quality reduced when uploading to homepage slider

Image quality reduced when uploading to homepage slider

Homepage Support Callisto Shopify Image quality reduced when uploading to homepage slider

This topic contains 5 replies, has 2 voices, and was last updated by  planetshine 8 months, 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #8894

    intellipet
    Participant

    Hi,

    I notice that slideshow images get a huge reduction in image quality. Not the size, but the quality. This is especially so for simple graphics and text, not photos. See attachments. I did resize the image to 944px x 324px but same result. Original size was 170-350kb but after upload it becomes 31kb.
    What I have tried with no results:
    – Upload PNG instead of JPG
    – Increased PPI
    – Export to maximum quality
    – Color profile sRGB

    Is there a way to not reduce image quality when uploading?

    Attachments:
    You must be logged in to view attached files.
    #8905

    planetshine
    Keymaster

    Hey,

    Can you give me a link to your site where I could check this out in action? Generally speaking image scaling is done by Shopify, but I’m quite surprised by this issue since I have not seen it before. Maybe you can try to use much larger images and allow Shopify to scale then down?

    #8912

    intellipet
    Participant
    This reply has been marked as private.
    #8924

    planetshine
    Keymaster
    This reply has been marked as private.
    #8934

    intellipet
    Participant

    I found that images are fine, but not images with texts. If you notice it in my picture comparison, only texts area are messy. It seems the problem is from shopify side. I googled “shopify reduce image quality”, many comes up but with no fix. Some examples but using other themes:
    Here
    Here
    Here

    Some suggest a temporary fix by changing asset_img_url: ‘master’ but I can’t find the code in Callisto theme.
    If there is still no fix, I have to find another way to present my website.

    #8944

    planetshine
    Keymaster

    The file you should edit is snippets/homepage-slider.liquid.

    Try replacing this:
    <a href="{{ settings.slider_item_1_link }}">{{ 'slider-item-1.jpg' | asset_url | img_tag: settings.slider_item_1_title }}</a>
    with this:
    <a href="{{ settings.slider_item_1_link }}">{{ 'slider-item-1.jpg' | asset_url | img_tag: settings.slider_item_1_title, '', 'master' }}</a>

    This should force the master size to be used for the first slider image. The rest can be edited in a similar way further down the file.

Viewing 6 posts - 1 through 6 (of 6 total)
You must have active support license to create new replies.

Learn more about Renewing Item Support and Themeforest Item Support Policy.

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close